Author Topic: Descriptions are Missing  (Read 4835 times)


  • Posts: 2
  • Maggot Crusher.
    • View Profile
Descriptions are Missing
« on: February 12, 2015, 03:59:51 AM »
Since no one appearantly cared about Steam forums, I wanted to report this bug here as well.

Any idea about that? Only ranger and warlock class has his description.

Problem is only at the medium for difficulty level. I have tried many things including a reinstall and a steam language setting change.

For your information i did not subscribed to any mods.


  • Posts: 2
  • Maggot Crusher.
    • View Profile
Re: Descriptions are Missing
« Reply #1 on: January 03, 2016, 12:57:05 PM »

I have found out that this bug is related with Turkish localized Windows. Let me summarize what is going on. In Turkish, there are two different letter for "I" and "i". Turkish has something like "I,ı" and "İ,i". So, your coding method for displaying class descriptions gets bugged out, because you did not use UTF8. Interface checks for something like "CLASS-THİEF" which does not exist in the files you are providing.

I have encountered with similar bugs in two other different games. Developer of one solved the problem, after I specify the reason, while the other just did not care.

Here are the relevant links: (for Transistor) (for Crayon Chronicles)

Btw, I should also include a solution for the ones who have the same problem. And that might also help you to replicate the bug, since it is directly related to windows time setting, I dont know how. To replicate the bug, do the same and change clock, language and region settings to Turkish(Turkey).

1-Go to control panel.
2-Find "Clock,Language and Region" Settings
3-From there change the formatting of time and date from Turkish to English(World)

I hope I wont be ignored this time.
« Last Edit: January 03, 2016, 01:03:20 PM by tombik »